Advanced Troubleshooting to Correct Problems With Quicken for Windows Data Files

Overview

Although data integrity problems do happen, often what is thought to be a data integrity problem turns out to be an issue with preferences or misinterpreting the data Quicken is displaying. Before troubleshooting data integrity issues, review your settings and preferences. Also, ensure you are on the latest release of the program.

Symptoms of data integrity issues can include:

  • Categories or numbers wrongly associated in reports when all report settings are correct.
  • Dates missing from reports when all report settings are correct.
  • Missing categories or tags.
  • Inability to assign categories in split transactions.
  • Data file backups that cannot be restored.

Note:  Always make a backup before performing complex procedures. This ensures that you have a "fall-back" file you can use to get back to where you were when you started.

First, Validate your file

  1. Accept any transactions that are waiting in the Compare-to-Register screen prior to Validating. This is in the Downloaded Transactions tab which is located at the bottom of your account register if you have transactions waiting to be accepted. 
  2. Click on File on the top menu bar, then select File Operations > Validate & Repair.
  3. If you are currently in the data file you would like to validate, it will already be selected.  If you want to validate a different file, then you will need to click Browse to locate that data file.
  4. Put a check next to Validate file.
  5. If you are experiencing investment-related issues, put a check next to Rebuild investing lots and Delete investing price history.
  6. Click OK.

After the Validation process is finished, you will see the Data_Log appear in a Notepad window. This file is a summary of the Validation results. Quicken saves a backup copy of this file before you Validate. This file is located in the Validate folder in the same location as your Quicken data file.

If you receive the message "Damaged data block" in the Data_Log after the Validation completes, the file is not repairable.  We recommend restoring a backup from prior to the date listed on this message.

 

Copy your file and Validate

If you are still experiencing issues (such as severe latency with just one account, unexpected data that cannot be resolved by Validate or Delete/Re-enter, or other conditions that indicate a data integrity issue) try these steps.

  1. Go to File > File Operations > Copy (do not choose Year End Copy for this procedure).
  2. Leave all of the settings, including file name and checkboxes, at their default (change nothing on this screen).
  3. After the Copy is complete, choose to Open New Copy.
  4. In the New Copy, go to File > File Operations > Validate & Repair > Validate to ensure there are no lingering issues with the data in this file.
    • If your issue was with Investment account(s) latency or other data issues with an investment account, be sure to also select Rebuild Lots during this procedure.
  5. When this process is complete, review the Data_Log.txt for messages pertaining to the quality of your data and resolve any that are advised with instructions you should follow.
  6. Test your regular procedure(s) to see if the issue you were encountering is now resolved.

If you require assistance through any of these steps, please contact Quicken Support.

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.