Updating Share Prices in Quicken for Mac



Automatic Quote Download

By default, security prices are updated automatically when you start Quickem and periodically as you use the product.

Quote Download on Demand Only

If you do not want to automatically update quotes when Quicken states you can opt-out of auto update in preferences.

  • Changing your security update preference
    1. Select Quicken > Preferences...
    2. On the General preferences tab un-check the Automatically Download Quotes option.

    If you opt-out of automatic quote downloads, Quicken will not attempt to download quotes and prices history when you launch Quicken.


    Instead you can go to any Portfolio View and click the Update Quotes button.


    You can also click Update Quotes button even if you're getting automatic quote download to fetch the latest, available quotes.

Manual Quote Update

If the security you wish to track is not available for download, then you can enter quotes manually as needed via the Security List.

  • Enter a security price manually
    1. Select Window > Securities.
    2. Double-cick the Security you wish to update to display the edit sheet.
    3. Click the Price History tab on the edit sheet.
    4. Enter the security price information into the form at the top of the page (only Closing Price is required)
    5. Hit Enter or click the Add button to save the price.
    6. Repeat as needed to enter multiple prices and then click Done to close the edit sheet.

Batch Updates / Price History Import

You can import price history data from an Comma Separated File (CSV) or rebuild a price history list from the Securities Window.

  • Import Price History from CSV file
    1. Select Window > Securities
    2. Double-click the Security you wish to update to display the edit sheet.
    3. Click the Options button and choose Import history from CSV file...
    4. Follow the instructions on the sheet that appears to complete import.

    NOTE: If importing a large file with many years of data, this import process may take a minute or two.

  • Rebuild Price History
    1. Select Window > Securities
    2. Double-click the Security you wish to update to display the edit sheet.
    3. Click the Options button and choose Rebuild price history...
    4. Choose the options for how to handle existing price history data.
      • Tell me more
        • If "Do not update Quotes that I entered manually" is checked, any manual entries or edits you made to the price history list will be left untouched and downloaded prices for those dates will be ignored. Un-check this to overwrite your entries with downloaded prices when they are available.
        • If "Do not delete quotes that cannot be replaced with downloaded values" is checked, then any existing quotes for dates that cannot be downloaded will be left untouched. Un-check to clear all previously downloaded price history values (even those which cannot be re-downloaded -- such as those over five years old).

        Leaving both options checked saves the most existing data. Leaving both options un-checked will delete and rebuild more of the existing price history.

    5. Click Rebuild.

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.