Backing up data files in Quicken for Mac



To back up a data file manually to a disk

  1. Choose File > Save a Backup.
  2. Select the location for the backup copy of your data file, and then click Save.
    • Tell me more
      Quicken copies the file to the backup location with a file extension of .quicken201*backup.

Restore a backup

  1. Choose File > Restore from Backup.
  2. Select the data file you wish to restore, and then click Choose
  3. Confirm the file you have selected in the window that pps up and click Restore this File...
  4. Select the location to restore the data file, and then click Save.

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.