Poodle Vulnerability


In response to the discovery of vulnerability in SSL 3.0, Intuit and our partner financial institutions turned off connectivity through this security protocol for the safety and protection of their customers’ data. This is a dated protocol that was used in Quicken Mac 2007 and earlier versions, and therefore, impacts connectivity. 

All currently supported versions of Quicken for Windows, Quicken Essentials for Mac and Quicken for Mac 2015 use newer and more secure protocols and are unaffected. 

We are working diligently with financial institutions to update Direct Connect functionality within Quicken Mac 2007 to support modern security protocols, and anticipate this work will take a few weeks.

We appreciate your patience and offer two alternative solutions in the meantime:

You may also want to consider upgrading to Quicken 2015, which has most of the same features as Quicken Mac 2007 and supports modern security protocols

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.