Quicken Browser Compatability



Information

Most browsers can be used with Quicken. However, Internet Explorer 6.x (or newer) with 128-bit SSL high-security encryption or higher is required to use many program features such as Registration, Retirement Planner, College Planner, and Debt Reduction Planner.

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.