Removing and Rebuilding Security Price History in Quicken Windows

Overview

The Quicken Price history file contains records for your security prices over time.  Occasionally this data becomes corrupted and needs to be rebuilt.  You can rebuild the price history file using the steps below.  Some data may be lost when doing this process.

Quicken 2011 & newer:

  1. Go to File > File Operations > Validate & Repair
  2. Select Delete Investing Price History
  3. Click OK
  4. When complete, go to the Investing tab
  5. Click the Update button
  6. Choose Historical Prices
  7. Choose 5 Years from the drop-down list
  8. Click the Mark All button
  9. Click the Update Now button

Quicken 2010:

Using Standard Menus:

  1. Make a backup of your Quicken data file.
  2. Press and hold down Ctrl-Shift keys and choose Investing > Investing Tools > Security Detail View.
  3. Click Yes when prompted to delete your security price history.
  4. Go to Investing > Download Activity > Historical Prices
  5. Select Five Years
  6. Click the Mark All button
  7. Click the Update Now button

Using Classic Menus:

  1. Make a backup of your Quicken data file.
  2. Open Investing Tab.
  3. Press and hold down Ctrl-Shift keys and choose Investing Tools > Security Detail View.
  4. Click Yes when prompted to delete your security price history.
  5. Open the Portfolio View.
  6. Click the Download Historical Quotes button.
  7. After downloading the Historical Quotes, click the Download Quotes button.

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.