Action Required: Critical Update Required in Quicken for Windows 2014, 2015 or 2016 (U.S. and Canada)

You will receive a Critical Update Required message if you're using the following Quicken for Windows product versions:

  • Quicken for Windows 2014 R8 or earlier versions
  • Quicken for Windows 2015 R9 or earlier versions
  • Quicken for Windows 2016 R3 or earlier versions

As part of Quicken’s continuous efforts to keep your data secure, you are required to use the latest Quicken update versions, which supports several security enhancements including Multi Factor Authentication (MFA).   

 

You must update before April 18th to keep access to online services (including bank downloads, investing quotes, and mobile sync).

Select your product below to download the latest Quicken release for your product:

 

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.