How do I import data into Quicken?

Quicken for Windows 2015
Quicken for Windows 2016
Quicken for Windows 2017

Quicken allows you to import data from select financial institutions, applications, and other versions of Quicken.

Before you begin

Please be aware that Quicken cannot import Excel (.xls), CSV (except to import security prices), Quickbooks, PDF, or OFX files.

Import Quicken data using a Web Connect file

  1. Log in to your financial institution's website.
  2. Navigate to the download page and click the Quicken logo or Download to Quicken. The exact location of the download page is determined by your financial institution. It is frequently in an area of the website identified as the Download or History area.
  3. Your browser will download a Web Connect file that contains your account transactions (you can recognize such a file by the .QFX extension in its file name).
  4. Return to Quicken and choose File menu > File Import > Web Connect File.
  5. Navigate to, and then select the Web Connect file you just downloaded.
  6. Click OK.
  7. Give the account a name. Or, if you already have an account in Quicken for these transactions, choose Link and the account name in the dialog that follows.
  8. After Quicken finishes importing the file, open the account. Quicken will either automatically add them to your register, or you can review and accept the imported transactions, depending on your downloaded preferences.

If this is the first time you're downloading transactions, see Activate an account to download transactions first.

Import Quicken data using a .QIF file

  1. Back up your Quicken data file.
  2. If the account you want to import data into doesn't yet exist, create a new one.
    • What types of accounts can I use?
      QIF import is available only for asset and liability accounts (including house and vehicle) and cash accounts. If you have purchased Quicken Home & Business, you can use QIF to import transactions into accounts payable accounts and invoice accounts as well. QIF import is also available for any exported list, but the file you want to import the list into must already include a valid account.
  3. If you're importing the data from an external disk, insert the disk and copy the QIF file onto your hard disk and copy the QIF file onto your hard disk.
  4. Choose File menu > File Import > QIF file.
  5. The Location of QIF file field displays the preset path of the import file. Select the appropriate option:
    • Enter a name for the import file at the end of the existing path (make sure there is a backslash \ before the file name). Quicken will automatically add the correct file extension.
    • Click Browse to select a different location. If you need help determining where a data file is, Quicken can help you find a file. Enter a name in the File name field, and then click OK to return to the QIF Import window.
  6. In the Quicken account to import into list, select the account you want to import the QIF file into.
    • Why aren't all my accounts included?
      This list is limited to accounts that can import QIF files. QIF import isn't available for checking, savings, or credit card accounts, or for 401(k) or any other brokerage accounts. 

      Note that to import a list such as the Category List, you must still choose a valid account.

  7. In the Include in import area, select the items you want to include in the import process.
    • Select the Transactions check box to import data from the account register.
    • Select the Memorized payees check box to include items from the Memorized Payee List.
    • Select the Account List check box to include items from the Account List.
    • Select the Special handling for transfers check box if you've exported to several QIF files from a number of Quicken accounts in the same file and are using Import to re-create all the transactions by importing from several QIF files. This choice prevents duplicate transfer transactions when you import data from both the to and from accounts involved with transfers.
    • Select the Category List check box to include items from the Category List.
    • Select the Security lists check box to include items from the Security List and the Security Prices List.
    • If you've purchased Quicken Home & Business, select the Business lists check box to include items from the Invoice Items List and the Business Templates List.
  8. Click Next, and follow the on-screen instructions.

Notes

You can import from lists without importing the transactions at the same time, a useful feature when you're setting up a new file.

Import Quicken data using a .QXF file

QXF (Quicken Transfer Format) is a file format used to share data between Quicken products. It is the preferred way to move and merge account data between versions of Quicken.

  • To create a new Quicken data file using an imported QXF file

1. Create a new Quicken file.
2. Choose File menu > File Import > Quicken Transfer Format (.QXF) file.
3. Type the name of the QXF file you want to import, or click the Browse button to select it.
4. Click Continue to begin importing the file.
5. If there are accounts in the QXF file that can't be imported, such as investing or business accounts, Quicken displays a list of those accounts.
6. You'll see a confirmation message when the process completes. If there are errors, you can click a link to review a log file that contains more information about the QXF import. This log file can also be reviewed later by choosing Help menu > Log Files.

  • To merge Quicken data files using an imported QXF file

1. Open the Quicken file you want to merge the QXF data into.
2. We recommend that you back up your existing Quicken file before merging QXF data into it. To do so, choose File menu > Backup and Restore > Backup.
3. Choose File menu > File Import > Quicken Transfer Format (.QXF) file.
4. Type the name of the QXF file you want to import, or click Browse to select it.
5. Click Continue to begin importing the file.
6. If there are accounts in the QXF file that can't be imported, such as investing or business accounts, Quicken displays a list of those accounts.
7. You'll see a confirmation message when the process completes. If there are errors, you can click a link to review a log file that contains more information about the QXF import. This log file can also be reviewed later by choosing Help menu > Log Files.

More information is available at Import data from a Quicken Transfer Format (.QXF) file.

Import TurboTax data using a .TAX file

If you have your previous year's TurboTax data file, you should import it into Quicken before you begin using the Tax Planner. Importing TurboTax data gives you a head start in developing your tax estimate and can save you a lot of data entry time.

  1. Choose File menu > File Import > TurboTax File.
  2. Select the TurboTax data file you want to import.
  3. Click OK.
  4. Choose the appropriate option:
  • Click Continue if this is the correct TurboTax file.
  • Click Change File if you want to select a different TurboTax file.
  1. If your TurboTax data file contains the filing status Married - Filing Joint, Quicken displays a dialog showing that the taxpayer on federal Form 1040 in TurboTax is the same person as Self in Quicken. (You can't switch the names for Self and Spouse in this dialog.) Click OK.
  2. Click OK to close the confirmation message that Quicken displays when the TurboTax import is complete.
  3. After importing the TurboTax information, view the TurboTax source information in the Tax Planner and update it where necessary.

More detailed information is available at Import a TurboTax data file.

Import security prices using a .CSV file

If you have an Internet connection, the easiest way to update security prices is to download them. Otherwise, you can import security prices from a standard, comma-delimited ASCII file.

  1. In the Investing tab, choose the Portfolio view.
  2. Choose File menu > File Import > Import security prices from CSV file.
  3. In the File field, enter the name of the ASCII  file that contains the price data. The data must be in an acceptable CSV format.
    • About using the CSV format for security prices
      The data must be in standard ASCII format with one symbol/price/date per line, separated by either commas or double spaces (using only one type of separator per line).

      These import formats are all acceptable. Note that Quicken can handle quotation marks:

      ABC, 123.456

      ABC, 123.456, 12/31/02

      ABC 123.456 12/31/02

      ABC, "ABC", 123.456, "12/31/02"

      "ABC", "123.456", "12/31

  4. In the Date field, change the date information if necessary.
    • Tell me more
      If the file doesn't contain specified dates, import the prices to the date entered here. The currently selected date in Portfolio is the preset display in this field.

      Quicken matches prices with your securities if they have the same symbol. If your securities don't have symbols, you'll need to edit them first so they do.

  5. Click OK.

Import Rental Property Manager V2 data

If you used Rental Property Manager v2, and want to bring your data into Quicken, you can import the data from Rental Property Manager to Quicken.

  1. Choose File menu > File Import > Rental Property Manager version 2 Data.
  2. Click Next.
  3. Follow the on-screen instructions.
  4. Verify that your data has been successfully imported to Quicken.

More information is available at Importing Rental Property Manager V2 data.

Import Microsoft Money data

If you are using Microsoft® Money 2007, 2008, or Money Plus Deluxe, you can convert your data for Quicken for Windows. More information is available on Quicken Support.

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.