Converting Your Data in Quicken for Mac

Quicken for Mac
Quicken for Windows

If you've used other versions of Quicken or other tools to manage your personal finances, you can convert your existing data file to Quicken for Mac compatible files (and in some cases, vice versa). 

What files can be converted

  • Quicken for Mac 2007, Essentials, 2015 and 2016
  • Quicken 2011 for Windows or newer versions.
  • Quicken Interchange Format - QIF files

Tips on converting your file

  • Don't delete your old data file until you've reviewed your new data file.
  • After you finish converting your data to Quicken 2016, you'll want to review the new file to make sure that everything got carried over correctly. You'll need to be able to view the old data file so you can compare balances and transactions.
  • It's a good idea to hold on to a backup of your old data file for a while, just in case you need to refer back to it.

Convert the file. If this is the first time you are using Quicken, Quicken guides you through setting up your bank accounts, downloading your transactions from the accounts, and adding new transactions.

Click the Quicken icon in your Applications folder to launch the program. You will see a brief tour of some of Quicken's features. 

Converting from Quicken Mac 2015 or 2016 to Quicken Mac 2017

After installing Quicken for Mac 2017, you will be prompted to select which version of Quicken you will be converting. When you are converting from Quicken for Mac 2015 or Mac 2016, follow the steps below.

  • Open Quicken Mac 2015 or Mac 2016 and Update your online accounts and scheduled transactions.  
  • Quit Quicken Mac 2015 or Mac 2016. The file can not be imported if Quicken Mac 2015 or Mac 2016 is running. 
  • Open Quicken Mac 2017. Select Start from a Quicken Mac 2015 file or Mac 2016 file. 
  • Click the Next button and choose the file to convert (or drag and drop the file on the window).
  • Click Next to convert your file.  
  • Wait while the conversion is processing.
    • How will I know if my data file is being converted?
      You'll see a message telling you that your data file is being imported
      Converting Your Data in Quicken for Mac

      Note: This could take a very long time if you have a very large data file (more than five or ten years of data) and/or an older computer.

  • Now your data should show up in Quicken. 

Note: Always check the account balances before and after the conversion.

Convert from Quicken for Mac 2007 to Quicken for Windows

Instructions for this process can be found here.

Please note that this is not a process that we can provide support for if you encounter a problem.

Convert Quicken for Mac 2015, 2016, or 2017 to Quicken for Windows

  1. Open your data file in Quicken Mac 2016 or Quicken Mac 2015.
  2. Choose File > Export > Quicken Windows Transfer File (QXF)....
  3. Save the .QXF file to media that will allow you to move it to your PC, such as a thumb drive or CD/DVD.
  4. Move the media (thumb drive or CD/DVD) to your computer running Windows.
  5. Open Quicken for Windows.
  6. Choose File > New Quicken File.
  7. Select New Quicken File, click OK.
  8. Name your new data file and press OK.
  9. Choose File > Import and then select the .QXF file from your media.

About QXF files

  • The import and export of financial data using the QXF file format is limited to the accounts, transactions, scheduled transactions, categories, and tags of non-investment and non-business accounts.
  • The import and export of investment and business accounts, transactions, budgets, attachments, reports, and application settings is not supported by QXF.
  • The QXF file format is the preferred choice for merging Quicken account data.
  • Quicken for Windows can import QXF data from Quicken for Mac. The only data imported is Checking, Savings, and Credit Card accounts and transactions.
  • Our legacy file transfer format, QIF (Quicken Interchange Format), has been replaced by QXF.

 

Start from an existing Quicken Essentials file

  1. Select Start from a Quicken Essentials File.
  2. You'll be prompted to choose the Quicken Essentials file you'd like to convert to Quicken 2017.
    • Tell me more

      Your existing Quicken Essentials file will be converted to a new Quicken 2017 data file and an unconverted copy of it will also be created.

      Your Quicken Essentials file to convert will end with the file extension .quickendata

  3. Next you'll be prompted to log in with the Intuit ID associated with your existing Quicken Essentials file.
    • Tell me more

      If you downloaded transactions from your financial institutions using Quicken Essentials we strongly recommend  that you log in with your existing Intuit ID when prompted. This will ensure that you are able to seamlessly continue downloading from your connected accounts after converting to Quicken 2017.

      If you are prompted to provide access to Mac Keychain, select Always allow.

      If you've never used connected services with Quicken Essentials (did not download transactions) you may be prompted to set up a new Intuit ID. You can use any existing Intuit ID by clicking Sign in with my Intuit ID or just create a new Intuit ID.

  4. If this is the first time you've used Quicken, you'll be asked to Register Quicken. 
  5. Next, you can opt in to use Quicken's Mobile app. Make your selection and continue.
  6. After these steps your Quicken Essentials data will be converted and you should see the Overview screen. All of your accounts will be accessible in the sidebar.

Start from an existing Quicken 2007 file

After installing Quicken for Mac 2017 you will be prompted to select which version of Quicken you will be converting. When you are converting from Quicken for Mac 2007 follow the steps below.

Note: Prior to converting your data file, make sure that it has no data file password; remove it if there is one. Disable downloading of transactions on all accounts. Disable "Pay bills online" on any current active accounts.

  • Select Start from a Quicken Mac 2007 file. 
  • Sign in using your Intuit ID, or create an Intuit ID
  • Select your Mobile preferences 
  • Open Quicken Mac 2007 and Update your online accounts and scheduled transactions.  
  • Quit Quicken Mac 2007. The file can not be imported if Quicken Mac 2007 is running. 
  • Click the Select button and choose the file to convert (or drag and drop the file on the window).
  • Click Next to convert your file.  
  • Wait while the conversion is processing
    • How will I know if my data file is being converted?
      You'll see a message telling you that your data file is being imported
      Converting Your Data in Quicken for Mac

      Note: This could take a very long time if you have a very large data file (more than five or ten years of data) and/or an older computer.

  • Now your data should show up in Quicken. 

Note: For Bill Pay in Quicken 2017, be sure that your account connection is set to Direct Connect. Click here for more information on connection types. Always check the account balances before and after the conversion.

Convert a Quicken Windows file

Instructions to convert a Quicken Windows data file can be found here

Start from a .QIF file exported from another application

Disclaimer

Quicken has no control over the data that is exported from other personal finance applications. As such, our import is only as good as the exported data provided in a .QIF file.

We want to make the transition to Quicken 2017 easy and have put a great deal of effort into handling issues related to missing or incorrect data that is imported from other personal finance applications.

However, we have found gaps or missing data in these exported QIF files, especially with investing transactions. As a result, some data clean up after import may be required after your data is imported into Quicken (see the known iBank and Moneydance issues below).

Please read these Help topics carefully to ensure a smooth transition to Quicken 2017:

  • iBank import issues and data clean up
  • Moneydance import issues and data clean up

Note: Personal finance applications other than iBank and Moneydance have not been tested for import in Quicken Mac 2016.

Quicken 2017 supports data import from other personal finance applications such as iBank and Moneydance. For this, you need to first export data from the other applications into a .QIF file and then import the .QIF file into Quicken for Mac 2017.

  • Export data from iBank to a .QIF file

    1. Open your iBank application. Select File >Export > QIF file.
    2. Make sure that you select all the accounts you wish to import into Quicken. Incremental import of QIF files into Quicken is not supported.
    3. Save the newly created QIF file and exit iBank.

  • Export data from Moneydance to a .QIF file

    1. Open your Moneydance application. Select File >Export.
    2. On the Export Date window, select Format: QIF and date: All Dates.
    3. Save the newly created QIF file and exit Moneydance.

  • Import an exported .QIF file into Quicken for Mac 2016

    1.    Open Quicken for Mac 2017.
    2.    Select File > New to start a new data file. The Let’s Get Started window is displayed.
    3.    Select the option Start from a .QIF file exported from another application.
    4.    You will be prompted to sign in or create a new Intuit ID.
    5.    You will be asked if you want to use Quicken’s Mobile app. Make your selection and continue.
    6.    Click Next. The Import data from another application window is displayed.
    7.    Follow the on screen instructions and import the .QIF file into Quicken.

After conversion please read these Help topics:

  • iBank import issues and data clean up
  • Moneydance import issues and data clean up

Search Support:

Search form

Tip: To find out which version of Quicken you are using, open Quicken go to Help menu and select About Quicken.